]> git.pld-linux.org Git - packages/libxml++4.git/blob - libxml++4.spec
- unconditional noarch subpackages
[packages/libxml++4.git] / libxml++4.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 %define glibmm_ver      2.68.0
6 Summary:        C++ interface for working with XML files
7 Summary(pl.UTF-8):      Interfejs C++ do pracy z plikami XML
8 Name:           libxml++4
9 Version:        4.0.0
10 Release:        1
11 License:        LGPL v2.1
12 Group:          Libraries
13 Source0:        https://download.gnome.org/sources/libxml++/4.0/libxml++-%{version}.tar.xz
14 # Source0-md5:  9612653c27f162ec1e62edda16268229
15 URL:            http://libxmlplusplus.sourceforge.net/
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  doxygen >= 1:1.8.9
19 BuildRequires:  glibmm2.68-devel >= %{glibmm_ver}
20 BuildRequires:  libstdc++-devel >= 6:7
21 BuildRequires:  libtool >= 2:2.2.6
22 BuildRequires:  libxml2-devel >= 1:2.7.7
23 BuildRequires:  mm-common >= 0.9.10
24 BuildRequires:  pkgconfig
25 BuildRequires:  rpmbuild(macros) >= 1.752
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 Requires:       glibmm2.68 >= %{glibmm_ver}
29 Requires:       libxml2 >= 1:2.7.7
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 libxml++ is a C++ interface for the libxml XML parser library.
34
35 %description -l pl.UTF-8
36 libxml++ jest interfejsem C++ do biblioteki libxml.
37
38 %package devel
39 Summary:        Header files for libxml++
40 Summary(pl.UTF-8):      Pliki nagłówkowe do libxml++
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       glibmm2.68-devel >= %{glibmm_ver}
44 Requires:       libstdc++-devel >= 6:7
45 Requires:       libxml2-devel >= 1:2.7.7
46
47 %description devel
48 Header files for libxml++.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe do libxml++.
52
53 %package static
54 Summary:        Static libxml++ libraries
55 Summary(pl.UTF-8):      Biblioteka statyczna libxml++
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static libxml++ libraries.
61
62 %description static -l pl.UTF-8
63 Biblioteka statyczna libxml++.
64
65 %package apidocs
66 Summary:        libxml++ API documentation
67 Summary(pl.UTF-8):      Dokumentacja API libxml++
68 Group:          Documentation
69 BuildArch:      noarch
70
71 %description apidocs
72 libxml++ API documentation.
73
74 %description apidocs -l pl.UTF-8
75 Dokumentacja API libxml++.
76
77 %package examples
78 Summary:        libxml++ - example programs
79 Summary(pl.UTF-8):      libxml++ - przykładowe programy
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description examples
84 libxml++ - example programs.
85
86 %description examples -l pl.UTF-8
87 libxml++ - przykładowe programy.
88
89 %prep
90 %setup -q -n libxml++-%{version}
91
92 %build
93 mm-common-prepare --copy --force
94 %{__libtoolize}
95 %{__aclocal} -I build
96 %{__autoconf}
97 %{__autoheader}
98 %{__automake}
99 %configure \
100         %{?with_static_libs:--enable-static} \
101         --disable-silent-rules
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
112
113 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libxml++-4.0.la
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS ChangeLog NEWS README
124 %attr(755,root,root) %{_libdir}/libxml++-4.0.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libxml++-4.0.so.1
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/libxml++-4.0.so
130 %{_libdir}/libxml++-4.0
131 %{_includedir}/libxml++-4.0
132 %{_pkgconfigdir}/libxml++-4.0.pc
133
134 %if %{with static_libs}
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/libxml++-4.0.a
138 %endif
139
140 %files apidocs
141 %defattr(644,root,root,755)
142 %{_datadir}/devhelp/books/libxml++-4.0
143 %{_docdir}/libxml++-4.0
144
145 %files examples
146 %defattr(644,root,root,755)
147 %{_examplesdir}/%{name}-%{version}
This page took 0.15615 seconds and 3 git commands to generate.